SolarBuster 0.1 beta - TEST PRELIMINARE

Discussioni relative al software di monitoraggio energetico METERN
Salvatore
Messaggi: 16
Iscritto il: 19/05/2017, 12:37

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda Salvatore » 17/03/2021, 20:45

Poiché ogni 2x3 mi si pianta il raspi sto (ri)provando con questa versione preimpostata da Flane.
Ho notato che l'installazione di 123solar, in configurazione, ha indicata la distro arch_ARM anziché la raspbian_ARM.
La domanda è: ma cambia qualcosa? Le chiamate al kernel hanno qualcosa di diverso?

Comunque sto pensando che questo piantamento (proprio totale!) di entrambi i raspi (modello 3 B) sia da imputare a guasti o cmq difetti fisici, dell'hardware. Mi sa che ne prendo qualche altro nuovo...

PS
non so se dipende dall'update, ma se faccio il boot con GUI, previa installazione di lightdm, si avvia la pagina di richiesta login, ma una volta inseriti nome e passwd va in loop, nel senso che... ritorna la videata con richiesta di login... (ovviamente entro via ssh, ma mi secca non capire quale possa essere la causa)

Ciaooo :-)


gtontini
Messaggi: 48
Iscritto il: 20/12/2020, 22:42

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda gtontini » 31/03/2021, 21:25

ciao Flane. Scaricato solar bluster su SD 16GB...2 volte.. file non corrotto .....sul mio RaspBerry mod. B rev 2 512 MB non parte .. si blocca il boot...
Ho rimontato SolarStrech sul quale come sai ho problemi con pooler485 che non genera i file in shm...

Zan77
Messaggi: 17
Iscritto il: 10/03/2021, 22:19

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda Zan77 » 31/10/2021, 12:09

Ciao a tutti.
Ho provato ad attivare l'avvio automatico di Domoticz al boot con la riga di comando indicata nella guida ma ottengo questo:

root@raspberrypi:/home/pi# sudo systemctl enable domoticz.service
Failed to enable unit: Unit /run/systemd/generator.late/domoticz.service is transient or generated.

Dove sbaglio?
Grazie.

s_p
Messaggi: 253
Iscritto il: 06/04/2017, 20:49

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda s_p » 31/10/2021, 19:20

preso dal forum di Domoticz e per me ha funzionato.

sudo chmod +x /home/pi/domoticz/domoticz.sh
sudo rm /etc/init.d/domoticz.sh

sudo nano /etc/systemd/system/domoticz.service

incollaci dentro questo

Codice: Seleziona tutto

[Unit]
After=network.target
Source=/home/pi/domoticz/domoticz.sh

[Service]
Type=forking
TimeoutSec=5min
IgnoreSIGPIPE=no
KillMode=process
GuessMainPID=no
RemainAfterExit=yes
SuccessExitStatus=5 6
ExecStart=/home/pi/domoticz/domoticz.sh start
ExecStop=/home/pi/domoticz/domoticz.sh stop
ExecReload=/home/pi/domoticz/domoticz.sh reload
Restart=on-failure

[Install]
WantedBy=multi-user.target


salva il file e chiudilo
sudo systemctl daemon-reload
sudo systemctl enable domoticz

riavvia e prova

Zan77
Messaggi: 17
Iscritto il: 10/03/2021, 22:19

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda Zan77 » 31/10/2021, 20:30

Funziona!!!
Grazie mille

crystaldj75
Messaggi: 12
Iscritto il: 18/01/2020, 10:50

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda crystaldj75 » 21/01/2022, 10:20

buongiorno vi chiedo se a qualcuno e' capitato di avere questo problema in fase di aggiunta sensori :
ho aggiornato come da guida il metern.py
ho riavviato
ma quando testo il sensore dht22 con il comando:

sudo ADHT_metern.py 22 4 6

il raspy risponde
Traceback (most recent call last):
File "/usr/local/bin/ADHT_metern.py", line 20, in <module>
import Adafruit_DHT

noto che in fase di avvio del raspy nella lista di controlli che esegue in boot mi dice che esiste un'errore su modulo adafruit

[ 16.815384] rc.local[504]: Traceback (most recent call last):
[ 16.817429] rc.local[504]: File "/usr/local/bin/ADHT_metern.py", line 20, in <module>
[ 16.821149] rc.local[504]: import Adafruit_DHT
[ 16.823511] rc.local[504]: ImportError: No module named Adafruit_DHT

GRAZIE IN ANTICIPO

jeppo17
Messaggi: 52
Iscritto il: 18/02/2019, 10:04

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda jeppo17 » 27/01/2022, 9:04

Ciao a tutti,

innanzitutto sempre grazie per il materiale messo a disposizione e gli aggiornamenti. Sono fondamentali...
Dopo alcuni anni era giunto il momento di passare a buster, ho usato l'immagine preconfigurata e ho poi ricostruito tutte le varie parti aggiunte nella mia versione funzionante, aggiornato con i backup dati e corretto le varie parti per avere anche Dashticz funzionante sullo schermo in soggiorno. Un po' a fatica... ma in qualche modo ci sono quasi.

Ho trovato qualche refuso che ho corretto, nelle comapps e in qualche impostazione (se serve cerco di indicare dove e cosa, diciamo le cose piu' "strane" sono ad esempio una parte mancante in "000-default.conf", una diffenza tra il wiki e la versione trovata in buster in "123solar.service" e una radice differente in uno script per inviare i dati di consumo a PVoutput tramite 123solar che legge il dato da meterN).
Ho poi dovuto re-installare anche domoticz per problemi di funzionamento.
Il mio sistema è a due contatori (uno produzione PV e uno consumi, una volta reso stabile il tutto con solarbuster cercherò di aggiungere un secondo contatore per la wallbox che per problemi "logistici" è indipendente e non sotto il main consumi casa), uso 123solar per il PV e meterN per il resto.

Ora ho un problema (viste le mie limitate capacità e conoscenze... magari di facile soluzione ma il difficile è capire da dove parte l'inghippo).
Tutto funziona, ma ogni mattina tra le 8:40 e le 8:45 123solar va in OFF !!!!! Poi lo riaccendo manualmente.. e tutto continua come se nulla fosse fono al giorno dopo. Nulla da segnalare nei log, questo l'orario di avvio

#1 27/01/2022 07:44:59 Clean up log, purging 1 csv
#* 27/01/2022 07:42:07 123Solar awake

quindi esattamente 1 ora dopo l'avvio.
Come posso capire il problema?
Grazie dell'aiuto !

EDIT:
aggiornamento al 30/1/2022

Ieri ho controllato con il comando df e ho notato /var/log era pieno al 100%
Ho fatto un po' di pulizia, ma il problema stamattina si è riproposto sempre alle 8:40
Nel debug di 123 solar ho questo

PHP Warning: Undefined array key "KWHT1" in /var/www/123solar/scripts/123solar.php on line 111
#* 30/01/2022 08:41:13 Starting 123Solar debug (24447)


e nei "running software" questo


www-data 24447 1 0 08:41 ? 00:00:39 php ../scripts/123solar.php
www-data 26374 24447 0 11:05 ? 00:00:00 sh -c sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0 2>&1
www-data 26375 26374 0 11:05 ? 00:00:00 sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0


provo ad installare tutto 123 solar da capo??

EDIT2:
aggiornamento del 2/2/2022
mi autorispondo, ho reinstallato 123solar da capo.
rinconfigurato tutto. funziona tutto
Ma ancora dopo 1 ora dall'avvio della mattina... va in OFF....

idee!???
capita a nessun'altro?

corylr
Messaggi: 12
Iscritto il: 07/10/2020, 18:48

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda corylr » 13/02/2022, 12:07

jeppo17 ha scritto:Ciao a tutti,

innanzitutto sempre grazie per il materiale messo a disposizione e gli aggiornamenti. Sono fondamentali...
Dopo alcuni anni era giunto il momento di passare a buster, ho usato l'immagine preconfigurata e ho poi ricostruito tutte le varie parti aggiunte nella mia versione funzionante, aggiornato con i backup dati e corretto le varie parti per avere anche Dashticz funzionante sullo schermo in soggiorno. Un po' a fatica... ma in qualche modo ci sono quasi.

Ho trovato qualche refuso che ho corretto, nelle comapps e in qualche impostazione (se serve cerco di indicare dove e cosa, diciamo le cose piu' "strane" sono ad esempio una parte mancante in "000-default.conf", una diffenza tra il wiki e la versione trovata in buster in "123solar.service" e una radice differente in uno script per inviare i dati di consumo a PVoutput tramite 123solar che legge il dato da meterN).
Ho poi dovuto re-installare anche domoticz per problemi di funzionamento.
Il mio sistema è a due contatori (uno produzione PV e uno consumi, una volta reso stabile il tutto con solarbuster cercherò di aggiungere un secondo contatore per la wallbox che per problemi "logistici" è indipendente e non sotto il main consumi casa), uso 123solar per il PV e meterN per il resto.

Ora ho un problema (viste le mie limitate capacità e conoscenze... magari di facile soluzione ma il difficile è capire da dove parte l'inghippo).
Tutto funziona, ma ogni mattina tra le 8:40 e le 8:45 123solar va in OFF !!!!! Poi lo riaccendo manualmente.. e tutto continua come se nulla fosse fono al giorno dopo. Nulla da segnalare nei log, questo l'orario di avvio

#1 27/01/2022 07:44:59 Clean up log, purging 1 csv
#* 27/01/2022 07:42:07 123Solar awake

quindi esattamente 1 ora dopo l'avvio.
Come posso capire il problema?
Grazie dell'aiuto !

EDIT:
aggiornamento al 30/1/2022

Ieri ho controllato con il comando df e ho notato /var/log era pieno al 100%
Ho fatto un po' di pulizia, ma il problema stamattina si è riproposto sempre alle 8:40
Nel debug di 123 solar ho questo

PHP Warning: Undefined array key "KWHT1" in /var/www/123solar/scripts/123solar.php on line 111
#* 30/01/2022 08:41:13 Starting 123Solar debug (24447)


e nei "running software" questo


www-data 24447 1 0 08:41 ? 00:00:39 php ../scripts/123solar.php
www-data 26374 24447 0 11:05 ? 00:00:00 sh -c sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0 2>&1
www-data 26375 26374 0 11:05 ? 00:00:00 sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0


provo ad installare tutto 123 solar da capo??

EDIT2:
aggiornamento del 2/2/2022
mi autorispondo, ho reinstallato 123solar da capo.
rinconfigurato tutto. funziona tutto
Ma ancora dopo 1 ora dall'avvio della mattina... va in OFF....

idee!???
capita a nessun'altro?



Ciao capita lo stesso anche a me da poco più di un mese e non ne sto venendo a capo...
Un workaroud che ho trovato è di riavviare il raspberry con un cron... mi è anche successo che alcune volte metern si blocca per un po' per poi riprendere a funzionare nuovamente...

Non capisco cosa possa essere successo... non vorrei che fosse qualche aggiornamento che ho fatto al raspberry che crea questi problemi...

Spero tu abbia trovato una soluzione da condividere...

s_p
Messaggi: 253
Iscritto il: 06/04/2017, 20:49

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda s_p » 13/02/2022, 12:29

jeppo17 ha scritto:Ciao a tutti,

innanzitutto sempre grazie per il materiale messo a disposizione e gli aggiornamenti. Sono fondamentali...
Dopo alcuni anni era giunto il momento di passare a buster, ho usato l'immagine preconfigurata e ho poi ricostruito tutte le varie parti aggiunte nella mia versione funzionante, aggiornato con i backup dati e corretto le varie parti per avere anche Dashticz funzionante sullo schermo in soggiorno. Un po' a fatica... ma in qualche modo ci sono quasi.

Ho trovato qualche refuso che ho corretto, nelle comapps e in qualche impostazione (se serve cerco di indicare dove e cosa, diciamo le cose piu' "strane" sono ad esempio una parte mancante in "000-default.conf", una diffenza tra il wiki e la versione trovata in buster in "123solar.service" e una radice differente in uno script per inviare i dati di consumo a PVoutput tramite 123solar che legge il dato da meterN).
Ho poi dovuto re-installare anche domoticz per problemi di funzionamento.
Il mio sistema è a due contatori (uno produzione PV e uno consumi, una volta reso stabile il tutto con solarbuster cercherò di aggiungere un secondo contatore per la wallbox che per problemi "logistici" è indipendente e non sotto il main consumi casa), uso 123solar per il PV e meterN per il resto.

Ora ho un problema (viste le mie limitate capacità e conoscenze... magari di facile soluzione ma il difficile è capire da dove parte l'inghippo).
Tutto funziona, ma ogni mattina tra le 8:40 e le 8:45 123solar va in OFF !!!!! Poi lo riaccendo manualmente.. e tutto continua come se nulla fosse fono al giorno dopo. Nulla da segnalare nei log, questo l'orario di avvio

#1 27/01/2022 07:44:59 Clean up log, purging 1 csv
#* 27/01/2022 07:42:07 123Solar awake

quindi esattamente 1 ora dopo l'avvio.
Come posso capire il problema?
Grazie dell'aiuto !

EDIT:
aggiornamento al 30/1/2022

Ieri ho controllato con il comando df e ho notato /var/log era pieno al 100%
Ho fatto un po' di pulizia, ma il problema stamattina si è riproposto sempre alle 8:40
Nel debug di 123 solar ho questo

PHP Warning: Undefined array key "KWHT1" in /var/www/123solar/scripts/123solar.php on line 111
#* 30/01/2022 08:41:13 Starting 123Solar debug (24447)


e nei "running software" questo


www-data 24447 1 0 08:41 ? 00:00:39 php ../scripts/123solar.php
www-data 26374 24447 0 11:05 ? 00:00:00 sh -c sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0 2>&1
www-data 26375 26374 0 11:05 ? 00:00:00 sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0


provo ad installare tutto 123 solar da capo??

EDIT2:
aggiornamento del 2/2/2022
mi autorispondo, ho reinstallato 123solar da capo.
rinconfigurato tutto. funziona tutto
Ma ancora dopo 1 ora dall'avvio della mattina... va in OFF....

idee!???
capita a nessun'altro?


corylr ha scritto:
jeppo17 ha scritto:Ciao a tutti,

innanzitutto sempre grazie per il materiale messo a disposizione e gli aggiornamenti. Sono fondamentali...
Dopo alcuni anni era giunto il momento di passare a buster, ho usato l'immagine preconfigurata e ho poi ricostruito tutte le varie parti aggiunte nella mia versione funzionante, aggiornato con i backup dati e corretto le varie parti per avere anche Dashticz funzionante sullo schermo in soggiorno. Un po' a fatica... ma in qualche modo ci sono quasi.

Ho trovato qualche refuso che ho corretto, nelle comapps e in qualche impostazione (se serve cerco di indicare dove e cosa, diciamo le cose piu' "strane" sono ad esempio una parte mancante in "000-default.conf", una diffenza tra il wiki e la versione trovata in buster in "123solar.service" e una radice differente in uno script per inviare i dati di consumo a PVoutput tramite 123solar che legge il dato da meterN).
Ho poi dovuto re-installare anche domoticz per problemi di funzionamento.
Il mio sistema è a due contatori (uno produzione PV e uno consumi, una volta reso stabile il tutto con solarbuster cercherò di aggiungere un secondo contatore per la wallbox che per problemi "logistici" è indipendente e non sotto il main consumi casa), uso 123solar per il PV e meterN per il resto.

Ora ho un problema (viste le mie limitate capacità e conoscenze... magari di facile soluzione ma il difficile è capire da dove parte l'inghippo).
Tutto funziona, ma ogni mattina tra le 8:40 e le 8:45 123solar va in OFF !!!!! Poi lo riaccendo manualmente.. e tutto continua come se nulla fosse fono al giorno dopo. Nulla da segnalare nei log, questo l'orario di avvio

#1 27/01/2022 07:44:59 Clean up log, purging 1 csv
#* 27/01/2022 07:42:07 123Solar awake

quindi esattamente 1 ora dopo l'avvio.
Come posso capire il problema?
Grazie dell'aiuto !

EDIT:
aggiornamento al 30/1/2022

Ieri ho controllato con il comando df e ho notato /var/log era pieno al 100%
Ho fatto un po' di pulizia, ma il problema stamattina si è riproposto sempre alle 8:40
Nel debug di 123 solar ho questo

PHP Warning: Undefined array key "KWHT1" in /var/www/123solar/scripts/123solar.php on line 111
#* 30/01/2022 08:41:13 Starting 123Solar debug (24447)


e nei "running software" questo


www-data 24447 1 0 08:41 ? 00:00:39 php ../scripts/123solar.php
www-data 26374 24447 0 11:05 ? 00:00:00 sh -c sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0 2>&1
www-data 26375 26374 0 11:05 ? 00:00:00 sdm120c -a 1 -b 9600 -P N -z3 -w10 -j10 -vpcfi -q /dev/ttyUSB0


provo ad installare tutto 123 solar da capo??

EDIT2:
aggiornamento del 2/2/2022
mi autorispondo, ho reinstallato 123solar da capo.
rinconfigurato tutto. funziona tutto
Ma ancora dopo 1 ora dall'avvio della mattina... va in OFF....

idee!???
capita a nessun'altro?



Ciao capita lo stesso anche a me da poco più di un mese e non ne sto venendo a capo...
Un workaroud che ho trovato è di riavviare il raspberry con un cron... mi è anche successo che alcune volte metern si blocca per un po' per poi riprendere a funzionare nuovamente...

Non capisco cosa possa essere successo... non vorrei che fosse qualche aggiornamento che ho fatto al raspberry che crea questi problemi...

Spero tu abbia trovato una soluzione da condividere...


ragazzi, ma il primo messaggio di questo tread lo avete letto?
nello specifico suggerisco la parte PROBLEMI NOTI

jeppo17
Messaggi: 52
Iscritto il: 18/02/2019, 10:04

Re: SolarBuster 0.1 beta - TEST PRELIMINARE

Messaggioda jeppo17 » 13/02/2022, 14:04

s_p ha scritto:
jeppo17 ha scritto:Ciao a tutti,

innanzitutto sempre grazie per il materiale messo a dispo

[...]

Spero tu abbia trovato una soluzione da condividere...


ragazzi, ma il primo messaggio di questo tread lo avete letto?
nello specifico suggerisco la parte PROBLEMI NOTI


Quale sarebbe il punto ?


Torna a “MeterN”

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti