Adattatori USB-RS485 "vestiti" neri

Varie tipologie di adattatori utilizzabili
max213
Messaggi: 13
Iscritto il: 13/11/2016, 20:30

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda max213 » 05/01/2017, 17:09

Buongiorno a tutti e buon anno. Riporto la mia esperienza con questi adattatori neri "vestiti", ne ho comprato 2 su Aliexpress che non andavano, dopo tante prove ho capito che era il chipset tipo PL2303x che il PI non vuole sapere di lavorare ( carica il drive per il PL2303 e non funziona). Dopo alcuni giorni ho comprato un modello su Amazon con chip tipo CH341D della SODIAL identico come forma, e per magia funziona tutto, sono 2 settimane che tutto va.


Avatar utente
Flane
Messaggi: 2376
Iscritto il: 16/01/2016, 15:02

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda Flane » 06/01/2017, 11:55

Effettivamente ci sono in rete le medesime chiavette come forma esterna, che in realtà montano al suo interno chip diversi.
Personalmente però non mi è mai capitato che non funzionassero sul raspberry.

rolandd
Messaggi: 50
Iscritto il: 10/05/2016, 13:06

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda rolandd » 17/06/2017, 19:44

help ho messo l adattatore di questo forum ma non so come collegarlo all inverter.A e B dove vanno? vevo un altro adattatore a tre fili, ora non so come collegare questo, help.
per il modbus invece ho usato sempre questo adattatore e funziona

Avatar utente
Flane
Messaggi: 2376
Iscritto il: 16/01/2016, 15:02

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda Flane » 18/06/2017, 10:40

roland, gli adattatori a 3 fili hanno A,B e GND
quelli a due fili hanno A e B

Devi pertanto collegare solo Questi due come A e B del tuo precedente adattatore.

Si collega A dell'adattatore con A dell'inverter e B dell'adattatore con B dell'inverter.

rolandd
Messaggi: 50
Iscritto il: 10/05/2016, 13:06

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda rolandd » 18/06/2017, 12:07

flane ho risolto, A è+ e B +-

ora ho un altro problema

rolandd
Messaggi: 50
Iscritto il: 10/05/2016, 13:06

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda rolandd » 18/06/2017, 12:08

ora quello dell inverte mi funziona, l altro del modbus no,
il modbus funziona (sul suo display leggo le misure) ma in metern mi da tutto zero

rolandd
Messaggi: 50
Iscritto il: 10/05/2016, 13:06

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda rolandd » 18/06/2017, 14:23

help

Davide
Messaggi: 12
Iscritto il: 29/05/2017, 19:36

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda Davide » 18/06/2017, 14:46

Personalmente ne acquistai il pacco da 10 da Aliexpress, dopo poco tempo uno è andato off. Sostituito con altro pezzo e tutto ok. Potrebbe essere rotto il chip. Non ne altri da testare?

rolandd
Messaggi: 50
Iscritto il: 10/05/2016, 13:06

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda rolandd » 18/06/2017, 14:53

Ne ho due. Uno del fotovoltaico e uno x il modbus. Li ho invertiti e il fotovoltaico funziona sull altro. È come se il modbus non comunicasse con il sensore

Davide
Messaggi: 12
Iscritto il: 29/05/2017, 19:36

Re: Adattatori USB-RS485 "vestiti" neri

Messaggioda Davide » 18/06/2017, 15:17

Prova. da terminale, a fare una lettura sul convertitore collegato al SDM con il comando:
sdm120c -a 1 -b 9600 -z 10 -ipvcfgot -P N -w 5 -j 10 -d 0 -q /dev/ttyUSB1
(Address SDM=1, USB collegamento= USB1 nel mio caso) e verifica la correttezza della risposta.

Cambia il convertitore ed effettua la stessa interrogazione; nel caso non ti rispondesse, con buona probabilità, il convertitore è off.


Torna a “Adattatori USB-RS485”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite