mqtt domoticz: connection refused

Configurazione ed uso di DOMOTICZ, versatile software free per la gestione domotica.
megamarco83
Messaggi: 184
Iscritto il: 22/08/2016, 14:13

mqtt domoticz: connection refused

Messaggioda megamarco83 » 18/09/2018, 15:11

ciao ho installato mqtt su stretch
poi in domoticz ho creato in hardware MQTT Client Gateway with LAN interface
ho messo come indirizzo localhost
come porta 1883
poi ho creato un sensore di temperatura dummy virtuale a cui domoticz ha assegnato indirizzo idx = 29
da terminale ho poi digitato:

Codice: Seleziona tutto

pi@raspberrypi:~ $ sudo mosquitto_pub -h localhost -m '{ "idx" : 29, "nvalue" : 0, "svalue" : "25.0" }' -t 'domoticz/in'
Error: Connection refused

ed ovviamente non mi si aggiornato il sensore virtuale in domoticz
se provo con:

Codice: Seleziona tutto

pi@raspberrypi:~ $ mosquitto -v
1537275083: mosquitto version 1.5 starting
1537275083: Using default config.
1537275083: Opening ipv4 listen socket on port 1883.
1537275083: Opening ipv6 listen socket on port 1883.
^C1537275087: mosquitto version 1.5 terminating

p.s. rimane in attesa fermo su 1537275083: Opening ipv6 listen socket on port 1883. se poi premo ctrl+C allora compare: 1537275087: mosquitto version 1.5 terminating


megamarco83
Messaggi: 184
Iscritto il: 22/08/2016, 14:13

Re: mqtt domoticz: connection refused

Messaggioda megamarco83 » 18/09/2018, 15:26

l'unico modo per farlo funzionare è dare il comando:

Codice: Seleziona tutto

mosquitto -d


poi il comando:

Codice: Seleziona tutto

pi@raspberrypi:~ $ mosquitto_pub -h localhost -m '{ "idx" : 29, "nvalue" : 0, "svalue" : "20.1" }' -t 'domoticz/in'

non da più errore ma non aggiorna nemmeno il sensore dummy, che segna sempre 0°C
se lo si rimanda per la seconda volta:

Codice: Seleziona tutto

pi@raspberrypi:~ $ mosquitto_pub -h localhost -m '{ "idx" : 29, "nvalue" : 0, "svalue" : "20.2" }' -t 'domoticz/in'

il sensore questa volta si aggiorna e segna 20.2°C

tutte le altre volte successive il comando funziona al primo colpo.

riavviando il raspberry, se non si da nuovamente il comando:

Codice: Seleziona tutto

mosquitto -d

si ha sempre l'errore connection refused.

come si fa a fare in modo che mosquitto sia già attivo in automatico al riavvio del raspberry?

Avatar utente
Flane
Messaggi: 2086
Iscritto il: 16/01/2016, 15:02

Re: mqtt domoticz: connection refused

Messaggioda Flane » 18/09/2018, 23:45

Sulla Solarstretch è già installato anche mosquitto.
In wiki è riportato come installare mosquitto e come abilitare il servizio per l'avvio al boot.

megamarco83
Messaggi: 184
Iscritto il: 22/08/2016, 14:13

Re: mqtt domoticz: connection refused

Messaggioda megamarco83 » 19/09/2018, 9:47

ciao Flavio, si è già instalallato (ho scritto io male dicendo che lo installato intendevo configurato su domoticz, scusa)
ad ogni modo sembra proprio che non parta all'avvio....
infatti se faccio un reboot e do il comando:

Codice: Seleziona tutto

pi@raspberrypi:~ $ sudo mosquitto_pub -h localhost -m '{ "idx" : 29, "nvalue" : 0, "svalue" : "25.0" }' -t 'domoticz/in'
Error: Connection refused

non funziona

se invece do il comando:

Codice: Seleziona tutto

 mosquitto -d

Codice: Seleziona tutto

pi@raspberrypi:~ $ mosquitto -d
pi@raspberrypi:~ $ sudo mosquitto_pub -h localhost -m '{ "idx" : 29, "nvalue" : 0, "svalue" : "25.0" }' -t 'domoticz/in'
pi@raspberrypi:~ $

come vedi funziona. anche se la prima volta che si esegue il comando:

Codice: Seleziona tutto

sudo mosquitto_pub -h localhost -m '{ "idx" : 29, "nvalue" : 0, "svalue" : "25.0" }' -t 'domoticz/in'

non aggiorna il sensore in domoticz, ma dalla seconda volta che si da il comando il poi, aggiorna immediatamente il sensore.

per far partire mosquitto all'avvio dalla wiki il comando è:

Codice: Seleziona tutto

pi@raspberrypi:~ $ sudo systemctl enable mosquitto.service
mosquitto.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable mosquitto

ma anche dopo il riavvio mosquitto non parte e bisogna sempre dare il comando:

Codice: Seleziona tutto

mosquitto -d

grazie

megamarco83
Messaggi: 184
Iscritto il: 22/08/2016, 14:13

Re: mqtt domoticz: connection refused

Messaggioda megamarco83 » 19/09/2018, 11:32

p.s.
ho trovato quest:
https://hobbytronics.pk/installing-mosq ... pberry-pi/
bisogna quindi fare così?

megamarco83
Messaggi: 184
Iscritto il: 22/08/2016, 14:13

Re: mqtt domoticz: connection refused

Messaggioda megamarco83 » 15/10/2018, 15:53

Flane ha scritto:Sulla Solarstretch è già installato anche mosquitto.
In wiki è riportato come installare mosquitto e come abilitare il servizio per l'avvio al boot.

ciao Flane forse ho capito perchè mosquitto non parte al riavvio ma occorre sempre lanciare a mano il comando:

Codice: Seleziona tutto

mosquitto -d

sembra che manchi
/etc/systemd/system/mosquitto.service
ma non ho capito come si fa a crearlo?

Avatar utente
Flane
Messaggi: 2086
Iscritto il: 16/01/2016, 15:02

Re: mqtt domoticz: connection refused

Messaggioda Flane » 15/10/2018, 19:17

Io sulla SolarStretch ho installato mosquitto come ho descritto in wiki ed ha funzionato tutto senza problemi:
Installare il Broker MQTT (Mosquitto)

Non ho nemmeno io il file /etc/systemd/system/mosquitto.service ma il servizio di mosquitto è attivo e si avvia al boot:

Codice: Seleziona tutto

root@raspberrypi:~# sudo systemctl status  mosquitto.service
● mosquitto.service - LSB: mosquitto MQTT v3.1 message broker
   Loaded: loaded (/etc/init.d/mosquitto; generated; vendor preset: enabled)
   Active: active (running) since Mon 2018-10-15 19:03:22 CEST; 16min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 368 ExecStart=/etc/init.d/mosquitto start (code=exited, status=0/SUCC
   CGroup: /system.slice/mosquitto.service
           └─439 /usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf

ott 15 19:03:22 raspberrypi systemd[1]: Starting LSB: mosquitto MQTT v3.1 messag
ott 15 19:03:22 raspberrypi mosquitto[368]: Starting network daemon:: mosquitto.
ott 15 19:03:22 raspberrypi systemd[1]: Started LSB: mosquitto MQTT v3.1 message

Il service è in /etc/init.d/mosquitto

megamarco83
Messaggi: 184
Iscritto il: 22/08/2016, 14:13

Re: mqtt domoticz: connection refused

Messaggioda megamarco83 » 15/10/2018, 19:49

Flane ha scritto:Io sulla SolarStretch ho installato mosquitto come ho descritto in wiki ed ha funzionato tutto senza problemi:
Installare il Broker MQTT (Mosquitto)

Non ho nemmeno io il file /etc/systemd/system/mosquitto.service ma il servizio di mosquitto è attivo e si avvia al boot:

Codice: Seleziona tutto

root@raspberrypi:~# sudo systemctl status  mosquitto.service
● mosquitto.service - LSB: mosquitto MQTT v3.1 message broker
   Loaded: loaded (/etc/init.d/mosquitto; generated; vendor preset: enabled)
   Active: active (running) since Mon 2018-10-15 19:03:22 CEST; 16min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 368 ExecStart=/etc/init.d/mosquitto start (code=exited, status=0/SUCC
   CGroup: /system.slice/mosquitto.service
           └─439 /usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf

ott 15 19:03:22 raspberrypi systemd[1]: Starting LSB: mosquitto MQTT v3.1 messag
ott 15 19:03:22 raspberrypi mosquitto[368]: Starting network daemon:: mosquitto.
ott 15 19:03:22 raspberrypi systemd[1]: Started LSB: mosquitto MQTT v3.1 message

Il service è in /etc/init.d/mosquitto


il mio è diverso....

Codice: Seleziona tutto

pi@raspberrypi:~ $  sudo systemctl status  mosquitto.service
● mosquitto.service - Mosquitto MQTT Broker
   Loaded: loaded (/etc/systemd/system/mosquitto.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Mon 2018-10-15 19:46:04 CEST; 9s ago
     Docs: man:mosquitto(8)
           man:mosquitto.conf(5)
  Process: 9671 ExecStart=/usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf (code=exited, status=1/FAILURE)
 Main PID: 9671 (code=exited, status=1/FAILURE)

ott 15 19:46:04 raspberrypi systemd[1]: mosquitto.service: Main process exited, code=exited, status=1/FAILURE
ott 15 19:46:04 raspberrypi systemd[1]: mosquitto.service: Unit entered failed state.
ott 15 19:46:04 raspberrypi systemd[1]: mosquitto.service: Failed with result 'exit-code'.

non capisco perchè
mosquitto funziona benissimo
però ogni volta che riavvio il raspberry devo lanciare a mano
il comando

Codice: Seleziona tutto

mosquitto -d

se non lo lancio mi da connection refused e mosquitto non si avvia
come posso lanciare in automatico il comando

Codice: Seleziona tutto

mosquitto -d
con stretch??
con questa architettura non so lanciare comandi in automatico al boot come si faceva con wheenzy
oppure puoi darmi il tuo service in /etc/init.d/mosquitto
grazie!

Avatar utente
Flane
Messaggi: 2086
Iscritto il: 16/01/2016, 15:02

Re: mqtt domoticz: connection refused

Messaggioda Flane » 15/10/2018, 21:50

Hai già provato a disabilitare e riabilitare il servizio, riavviando il raspi dopo ogni operazione?
Tu come lo hai installato, come da procedura che ti ho indicato?

Il consiglio eventualmente è quello di disinstallare mosquitto e reinstallarlo seguendo la procedura indicata.

megamarco83
Messaggi: 184
Iscritto il: 22/08/2016, 14:13

Re: mqtt domoticz: connection refused

Messaggioda megamarco83 » 15/10/2018, 23:44

Flane ha scritto:Hai già provato a disabilitare e riabilitare il servizio, riavviando il raspi dopo ogni operazione?
Tu come lo hai installato, come da procedura che ti ho indicato?

Il consiglio eventualmente è quello di disinstallare mosquitto e reinstallarlo seguendo la procedura indicata.

ho rifatto tutto da capo ed ora funziona
però ho visto nel repistory di mosquitto che ora è presente la versione per stretch
bisogna quindi cambiare rispetto al wiki il comando:

Codice: Seleziona tutto

sudo wget http://repo.mosquitto.org/debian/mosquitto-jessie.list

con

Codice: Seleziona tutto

sudo wget http://repo.mosquitto.org/debian/mosquitto-stretch.list


Torna a “Domoticz”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite